This application process requires Adobe Reader 8.0 or later to sign documents (Google Chrome built in PDF reader will not work!). If it is not already installed on your computer, you can get it here